Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

You need HAProxy 1.8.1 or later to enable TLS 1.3 support. We are using 1.8.13.

Code Block
languagebash
titleBuild haproxy
sudo apt install build-essential libpcre2-dev zlib1g-dev


wget https://www.haproxy.org/download/1.8/src/haproxy-1.8.13.tar.gz
tar -xzf haproxy-1.8.13.tar.gz
cd haproxy-1.8.13/
make TARGET=linux2628 CPU=native USE_PCRE2=1 USE_PCRE2_JIT=1 USE_OPENSSL=1 SSL_LIB=/opt/openssl-1.1.1/lib SSL_INC=/opt/openssl-1.1.1/include USE_ZLIB=1
sudo make install


# Edit the haproxy.service unit file and ensure you have
[Service]
Environment=LD_LIBRARY_PATH=/opt/openssl-1.1.1/lib/

...